Uploaded image for project: 'Spigot'
  1. Spigot
  2. SPIGOT-6956

setKeepSpawnInMemory(false) works great, but causes shutdowndown to hang

    XMLWordPrintable

Details

    • Bug
    • Resolution: Fixed
    • Minor
    • None
    • None
    • Windows 10
      Azul Zulu 17.0.2+8 (17.32.13)

    • 3446-Spigot-fb0dd5f-6e75502 (MC: 1.18.2) (Implementing API version 1.18.2-R0.1-SNAPSHOT)
    • Yes

    Description

      when setKeepSpawnInMemory is set to false on a world it causes server shutdown to hang on saving worlds. Eventually this hang causes spigot to stop responding.

       

      In order to reproduce this bug you must:

      1: install the attached plugin on your server. (it's a minimal reproducer jar).

      2: log in and alter the world. (break some blocks)

      3: shutdown the server. (/stop command)

      provided attachments are the log and a minimal reproducer plugin jar.

       

      I spent 1 hour ensuring that to the best of my ability this indeed appears to be a bug.

      This was not an issue in 1.18.1 from what i can tell.

      Attachments

        1. latest.log
          43 kB
        2. NoSpawnChunks.jar
          2 kB
        3. NoSpawnChunks.java
          0.5 kB
        4. plugin.yml
          0.1 kB
        5. Spigot1.PNG
          Spigot1.PNG
          48 kB
        6. Spigot2.PNG
          Spigot2.PNG
          141 kB

        Activity

          People

            Unassigned Unassigned
            gizmo gizmo
            Votes:
            1 Vote for this issue
            Watchers:
            8 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: