Uploaded image for project: 'Spigot'
  1. Spigot
  2. SPIGOT-6505

Error converting worlds from 1.16.5

    XMLWordPrintable

Details

    • Bug
    • Resolution: Fixed
    • Major
    • None
    • None
    • This server is running CraftBukkit version 3101-Spigot-c9cea60-5182f92 (MC: 1.17) (Implementing API version 1.17-R0.1-SNAPSHOT)
    • Yes

    Description

      Server crashes while converting world from 1.16.5. I am using --forceUpgrade argument and no plugins.

      "java.lang.NullPointerException: Cannot invoke "net.minecraft.world.level.levelgen.GeneratorSettings.d()" because the return value of "net.minecraft.world.level.storage.WorldDataServer.getGeneratorSettings()" is null"

      Attached the log.

      Attachments

        Activity

          People

            Unassigned Unassigned
            MrRockis Joni
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: