Uploaded image for project: 'Spigot'
  1. Spigot
  2. SPIGOT-3595

net.minecraft.server.v1_12_R1.TileEntityHopper.o() 80.1% 240300ms

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Environment:
    • Plugin:
      WorldGuard

      Description

      I am new, but I will try to provide clear and useful information.

      Since 1.12.2 I experienced major TPS lag. Narrowed the issue down to WorldGuard, but the developer believes it is a bug in Spigot.

      Seems like there was an update to hoppers and this is causing some CPU drag.

      1) CPU profile generated by WorldGuard [http://paste.enginehub.org/HNZpQO.profile
      ]

      Note that Hoppers are using up roughly 80%. 

      2) Contact with developer of world guard (lower comments)
       http://dev.enginehub.org/youtrack/oauth?state=%2Fyoutrack%2Fissue%2FWORLDGUARD-3870

      3) Additional images for context* Note: TPS was 10 on server. Screenshot from offline/independant test.
      https://www.spigotmc.org/attachments/2017-10-02_17-30-50-png.285364/

       

      4) Temporary workaround by removing WorldGuard.

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              NullCase NullCase
            • Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: